I am currently working through building my Taxonomy in Content Hub and working through sending it to Sitecore through CMP. As of right now I have a trigger set up that sends any new Assets from Content Hub to Sitecore along with my Taxonomy field in question. I have the incoming taxonomy set up as a Tag Field Mapping in Sitecore. However, it always imports the tag the same way no matter what Leaf Node or Store Tag Name options I have set.

When looking through the API I have noticed that the relationship field name: TaxonomyName only imports the assigned value of my Taxonomy and not the full hierarchy path. As you can see here: enter image description here

I would assume that I do not have one of the configurable items set up correctly in Content Hub, but I am not sure exactly what I am missing.

Can anyone please tell me what settings I need on the Taxonomy field to have access to the full hierarchy path in Sitecore?


I figured I would try to expand on my question to hopefully be a little bit more explicit with what I am looking to do/trying to understand.

Looking in the the CMP documentation for Content Hub here: CMP documentation

It provides all of the settings for a Tag Field Mapping to achieve different types of taxonomy imports as Sitecore Tags. In th the documentation it says:

For example, say you have a taxonomy in the content hub that has the hierarchy Company/Sitecore/Content Hub/Blog. You also have an item that has been tagged with Blog.

Followed by showing this table: enter image description here

I currently have a hierarchy taxonomy assigned to my asset with the path Top Level Brand/Accessory. According to the documentation above... I would think that if I have Non-Leaf Node set to Enable and Store Tag Name Option Asset toNode NameI should get the following tags associated to my imported item:Top Level BrandandAccessory`.

Am I missing something here? Can anyone provide any insight on what needs to be done to achieve what I am looking for?


And for just to clarify. I am getting the tag coming through, but not the full hierarchy that is to be expected. Here is a screenshot of what I am getting:

enter image description here

When I should be expecting something like Brand.Advertisement.

2 Answers 2


I am quiet new to Content Hub and now about Sitecore Experience but I may be able to help you with the Content Hub API.

It seems that with the Content Hub API you will not have the full hierarchy but just the parent and children of your entity. So, in your example, your entity id is 34159 (from self.href) and its parent id is 34210 (from parent.self).

Isn't the href of the parent object what you are looking for ?


Content Hub REST API Documentation : https://docs.stylelabs.com/content/4.0.x/integrations/rest-api/resources/Entity.html#get-apientitiesid

  • thank you for the response! I am also pretty new to Content Hub and am trying to get my feet wet. I checked out the href for the parent object and didn't really see anything I was looking for at first glance. I updated my question above to provide more information on what I am trying to achieve. Please review and let me know if that makes more sense as to what I am trying to accomplish. Thanks! Commented Jul 15, 2021 at 13:10
  • @scapegoat17 I understand the same as you of the documentation you have provided, but I don't know anything with Sitecore Experience. But your result looks like a GET on the Content Hub Rest API see the doc here have you tried to open the href links in a browser to see the JSON data ?
    – mlel
    Commented Jul 20, 2021 at 14:49
  • Yes I have tried. The only thing that I see as relative is the path property however, I don't see how any of that ties back to Setting up a Tag Field Mapping in Sitecore. This is my current roadblock right now. I do not see anything in documentation that specifies any more information on the matter... Commented Jul 21, 2021 at 19:57
  • Also just to add on to the above. I attached a screenshot of my Tagging section under EDIT 2. To show that I am getting tagging to come through but not with the full hieratical path as expected and what you have. Commented Jul 22, 2021 at 18:29

I've hit the same exact problem, what was causing this functionality not to work for us was having a dot character in the name of the taxonomy, e.g. we had Content.Topic as the taxonomy name, here is what it looked like:

enter image description here

I've had Sitecore support confirm this as a bug, to fix it we simply renamed our taxonomy to Topic rather than Content.Topic, I'm not sure if you've set this up in a similar way or not but it might be cause of your problem


On second glance, I can see the API response is slightly different to mine as well, here is the relation in my API response, there is just a single href:

enter image description here

My setup in the schema looks like this:

enter image description here enter image description here

When I added this member, I selected the Taxonomy option, I didn't really have to change any of the settings,

My Sitecore mapping looks like the following:

enter image description here

The tagging should look something like this if it's working:

enter image description here

  • Thanks for the response! Perhaps it could be part of the problem. However, I removed the dot character from the taxonomy and am still running into the same problem. I was wondering if you would be able to post the settings you used for adding the taxonomy to the schema and perhaps a screenshot of what the relations section looks like from the Entities API? Thank you so much for reaching out! I am hoping you might be able to get me on the right track still! Commented Jul 22, 2021 at 15:51
  • No problem I've just added some screenshots to my original answer, on second glance I can see there's a difference in the entities API response which might be causing your issue, hope it helps! Commented Jul 22, 2021 at 17:53
  • Thank you again for the detailed update! The only two differences I can see between your instance and mine is that 1) yours is a M.Content and mine is M.Asset 2) Your tagging goes to TagRepository and mine goes to the CachedItemTagRepository. Would you happen to know if this is something that could hinder that tagging structure from working? I wonder if it being an M.Asset` would be why your API looks a little different from mine? Commented Jul 22, 2021 at 18:22
  • Also just to add on to the above. I attached a screenshot of my Tagging section under EDIT 2. To show that I am getting tagging to come through but not with the full hieratical path as expected and what you have. Commented Jul 22, 2021 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.