0

I am new to Sitecore and working on a Sitecore 10.1 JSS project. For the Spanish(es) version of the page When I add an internal link in XM, it resolves the link as an English one and doesn't append es in the URL. Although not sure if this is expected behavior but can anyone let me know how can we resolve the internal links to the correct URLs having es appended in the URL.

2

You can change this behavior by updating the "languageEmbedding" setting in the LinkManager configuration (asNeeded, always, never):

<sitecore>
    <linkManager>
        <providers>
            <add name="sitecore">
                <patch:attribute name="languageEmbedding" value="always" />
            </add>
        </providers>
    </linkManager>
</sitecore>

But keep in mind that even if the language is not being embedded in the URL doesn't mean Sitecore won't resolve it in the proper (context) language.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.