1

I am new to Sitecore. We are using Sitecore SXA and Sitecore 9.3. I need to set up a simple A/B rendering test. When I provide a variation for the test in Experience Editor and click ok (see Picture below),

enter image description here

Then press save button, the page becomes unavailable and throws the following error:

[NullReferenceException: Object reference not set to an instance of an object.]
Sitecore.ContentTesting.Pipelines.EvaluateTestExposureBase`1.Process(TPipelineArgs args) (Object , Object )
Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args)
Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain, Boolean failIfNotExists) Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain)
Sitecore.Mvc.Pipelines.PipelineService.RunPipeline(String pipelineName, TArgs args)
Sitecore.Mvc.Routing.RouteHttpHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)
System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step) System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Does anyone how to fix it? I tried to deploy all Market Definitions, however, it didn't help. Thanks in advance.

1
  • This could be a Sitecore bug, you should contact Sitecore support for this. There is an EvaluateTestExposureBase error related KB article suggesting a hotfix -support.sitecore.com/… Jul 26 at 6:37
0

In my case, the solution was to accept cookie of website. However, to make it work without cookie consent, I think you need to go to support since it is bug of Sitecore (https://support.sitecore.com/kb?id=kb_article_view&sysparm_article=KB0647546).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.