My Sitecore commerce installer is throwing an error 404 when it tries to access the page http://sxa.sotefront.com/SiteUtilityPages/Installmodules?=...

I made sure my Sitecore XP installer doesn't get interrupted and that the XP is working.

Any idea what could be causing this problem?

Sitecore Commerce Installer

2 Answers 2


When you install Sitecore Commerce then it adds a new binding for storefront. You can see the name in your Sitecore Commerce installation file "Deploy-Sitecore-Commerce.ps1". There you can find the hostname provided in "$SiteHostHeaderName" variable.

Can you please double check if you can access your storefront with "http://sxa.sotefront.com" url. Please notice it has http protocol. Please check if "sxa.sotefront.com" binding added with http protocol on your Sitecore site in IIS.

If it still not work then check you have this "InstallPackages.aspx" page in "SiteUtilityPages" folder in your Sitecore site.

  • my $SiteHostHeaderName is sxa.storefront.com. I can't access the http:\\sxa.storefront.com URL. These are my Sitecore site iss bindings, "https:*:443:sc10sc.dev.local,https:*:443:sxa.storefront.com,http:*:80:sxa.storefront.com" I don't have InstallPackages.aspx in my Sitecore site. The closest thing I have is InstallModules.aspx
    – ffomar
    Jul 27, 2021 at 13:36
  • Seems "http:\\sxa.storefront.com" binding exists in your iis "http:*:80:sxa.storefront.com". Can you please check in your host file if you have entry for sxa.storefront.com and it's pointing to for ex. " sxa.storefront.com" in C:\Windows\System32\drivers\etc\hosts file. Jul 27, 2021 at 13:44
  • Also share the error or message getting while accessing http:\\sxa.storefront.com site. Jul 27, 2021 at 13:47
  • when I access it in chrome all I get is "404 page not found" in plain black text over white page
    – ffomar
    Jul 27, 2021 at 13:53
  • Do you have entry for "sxa.storefront.com" in your host file? Jul 27, 2021 at 14:00

The problem was that I had Sitecore commerce 9 installed. So there were two sxa.store.front domains in my host file, XC9 and XC10, which mapped to different ips. I commented out Sitecore commerce 9 sxa.store.front from the host file and the commerce installer worked.

Not the answer you're looking for? Browse other questions tagged or ask your own question.