I've installed Coveo (pro cloud edition with the October 2016 package), and after installation I went and changed the farm name and Sitecore account it was using (the account I switched to is still an administrator account). When I tried to access the diagnostic page, I got a YSOD message with "No SecurityProviderConversionHelper found for index: Coveo_master_index." Looking around, I thought it could be because I hadn't kicked off an initial index yet, but when I go to the indexing manager, I get the same error. I don't see this message around the developer or answers sites on Coveo, so assistance appreciated.


It is a bug introduced with the October package (4.0.450) happening when upgrading and changing the Sitecore account. We are looking for solutions on our side.

  • Thanks - I submitted a ticket like we discussed on Slack, so I should be in the system now. Nov 29 '16 at 15:23
  • Hotfix confirmed to be coming soon, will post the link when it's done for folks to know about. Nov 29 '16 at 16:21
  • Should note, Coveo sent me a hot fix for the issue, but has also updated the October release to version 704, which should resolve this issue. Dec 9 '16 at 1:23

Did you synchronize after you changed the farm name? You could also do a reindex or a publish.

But I recommend you making sure the configs look good, followed by doing a security cache flush and synchronize.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.