2

We are using Sitecore 9.1 and SXA. When we try to open any page in the Experience Editor, Publish button is not getting displayed under the Home tab. This is not happening over all the environments.

enter image description here

2
  • Is it like that for Administrator as well? Have you checked that button in core database? Does it have correct access rights? Is there any "Deny" rule? Does it even exist?
    – Marek Musielak
    Aug 11, 2021 at 8:18
  • Yes...it is for admin role. I checked that button exists in core db and don't have any deny access. Aug 11, 2021 at 11:49

2 Answers 2

1

Simple Solution:

To mitigate this quickly you can create the Package for the below item from the working environment and publish it back to the instance where it has a problem.

/sitecore/content/Applications/Content Editor/Ribbons/Chunks/Publish

This might solve your issue quickly and later you can compare what was the difference.

Solution 2:

Check if you have below item configured correctly in your stripe

/sitecore/content/Applications/Content Editor/Ribbons/Strips/Publish/Publish

Solution 3:

Check if the page you are trying to publish is under any custom workflow which has this rule as part of workflow.

Solution 4: Raise ticket to Sitecore Support.

1

I see only two possible options that might hide this button in Experience Editor:

  1. Check security configuration of /sitecore/content/Applications/WebEdit/Ribbons/WebEdit/Page Editor/Publish/Change Restrictions item in core database. The current user might not have read permissions. I see the following security details on my Sitecore instance: enter image description here

  2. Button state also depends on Sitecore.ExperienceEditor.Speak.Ribbon.Requests.PublishRestrictions.CanChangePublishRestrictions.CanChangeRestrictions code:

    protected virtual bool CanChangeRestrictions(Item item) => Sitecore.Configuration.Settings.Publishing.Enabled && TemplateManager.IsFieldPartOfTemplate(Sitecore.FieldIDs.PublishDate, item);

So, if you don't use the Commerce server then please check if your current item contains the PublishDate({86FE4F77-4D9A-4EC3-9ED9-263D03BD1965}) field.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.