1

I was using Sitecore 8.2 then upgraded to Sitecore 9.3, after the upgrade process, when I publish any item, I noticed that the index is not updated, I must trigger a full rebuild for the index to be updated.

I checked the index update strategies, but it's the default ones, I checked the Crawling log file, during the publish process, there are no logs in there, it's like the update index process is not triggered at all, but I found this at the log file after I restarted the instance.

The event queue is enabled, and I tried cleaning it and also the publishing queue, but still nothing happens.

FATAL [Index=sitecore_master_index] Initialization of IntervalAsynchronousStrategy failed because event queue is not enabled.

FATAL [Index=sitecore_web_index] Initialization of OnPublishEndAsynchronousSingleInstanceStrategy failed because event queue is not enabled.

6
  • how did you make sure event queue is enabled? Aug 13 at 20:13
  • @JonKoivula its value is true in Sitecore.config, <setting name="EnableEventQueues" value="true" /> Aug 13 at 20:15
  • please do a show config and check your config updates there to validate. Aug 16 at 4:10
  • @MahendraShekhawat I did this, event queue is enabled, and actually I didn't do any config updates, it was enabled by default Aug 16 at 5:58
  • @MohamedYaseen can you please make sure from showconfig.aspx also that it is enabled? Aug 16 at 10:35
0

I would suggest clearing your eventqueues, Publish queues and the properties tables as shown below. With upgrades and moving servers, there is a chance these get stuck because of machine name changes

TRUNCATE TABLE [dbo].[EventQueue];
TRUNCATE TABLE [dbo].[PublishQueue];
delete from properties where not [key] like  '%ENCRYPTIONKEYS%' 

If it still doesnt work after this, the next thing to check once you publish if the EventQueue tables in the web databases are getting populated properly. If it is not getting in there, then some pipelines are missing. To diagnose, compare your showconfig.aspx to a clean install of 9.3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.