0

I have the Sitecore 9.0.1 installed along with the Sitecore PowerShell version 4.7.2 . For some requirements need to Upgrade the Sitecore PowerShell version to 5.0 . Can anyone please help in upgrading Sitecore PowerShell version from 4.7.2 to 5.0 .

enter image description here

Thanks

1
  • Check out the #spe channel on the Sitecore Slack Chat. You'll be able to get more interactive support there. You would be better of upgrading straight to the latest version. Delete the old Cognifide configs/dlls and then install. Sep 8 at 15:29
1

You can download Sitecore Powershell from the marketplace - https://marketplace.sitecore.net/en/Modules/Sitecore_PowerShell_console.aspx

You can find the latest releases in github instead of market place. You can take a look at the features of each release and download any version from https://github.com/SitecorePowerShell/Console/releases

But before updating make sure to look at the compatibility table - https://doc.sitecorepowershell.com/appendix

I can see that Sitecore 9.1 is compatible with Powershell 5.0, so you can download it and install it.

enter image description here

3
  • can i install it above the existing powershell version 4.7.2? If i install it on top of the existing one will this create any issues? @Gaurav Agarwal
    – Vinaya
    Sep 8 at 15:33
  • You can follow this blog - blog.najmanowicz.com/2015/02/27/… You may need to take a backup of your existing script etc. Sep 8 at 15:37
  • I have seen this blog but that is for older PSE versions . In 4.7.2 the folder structure is different when compared with this blog @Gaurav Agarwal
    – Vinaya
    Sep 8 at 15:40
0

Download the PowerShell version 5.0.0 from here. https://dev.sitecore.net/Downloads/Sitecore_Experience_Accelerator/19/Sitecore_Experience_Accelerator_190.aspx

It will redirect you to the download page same as below: How to Install Sitecore Module or Package

enter image description here

Click on the highlighted one in the image, it will start a download your PSE 5.0.0 package.

Once you complete your download, install that Package in your Sitecore instance and opt to overwrite for all options. See the blog post: How to Install Sitecore Module or Package

For more details see the blog post: PowerShell with Sitecore and Installation

3
  • I want to upgrade the existing powershell..can you please tell how can i do that @Himmat Singh Dulawat
    – Vinaya
    Sep 8 at 16:57
  • As I suggested in the above answer download the version in which you want to upgrade your PSE. Install that package, it will upgrade your Powershell. Sep 8 at 17:48
  • @Vinaya I have updated the answer, specific to your requirement. Sep 8 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.