0

I tried to setup the development environment for Sitecore Commerce 10 with visual studio. I can able to run Customer.sample.solution without any build error but while trying to navigate to the Business tool it shows below error message in the log file.

ERROR SQL.GetEntities.Fail: Id='List-CONTENTPATHS-ByDate'|Environment='Entity-CommerceEnvironment-HabitatAuthoring'|Message='Login failed for user 'xxx/yyy'.'|Number='18456'|Procedure=''|Line='65536'|Number='18456'
ERROR CtxMsg.Error.SqlException: Text=SQL:block:findentitiesinlist.Exception: Login failed for user 'xxx/yyy'.
ERROR Pipeline completed with errorSystem.ObjectDisposedException: Cannot access a disposed object.
Object name: 'IServiceProvider'.
   at Microsoft.Extensions.DependencyInjection.ServiceLookup.ThrowHelper.ThrowObjectDisposedException()
   at Microsoft.Extensions.DependencyInjection.ServiceLookup.ServiceProviderEngineScope.GetService(Type serviceType)
   at Microsoft.Extensions.DependencyInjection.ActivatorUtilities.GetServiceOrCreateInstance[T](IServiceProvider provider)
   at Sitecore.Framework.Pipelines.Definitions.AddPipelineBlockDefinition`1.Build(IServiceProvider services)
   at Sitecore.Framework.Pipelines.DefaultPipelineBlockRunner.RunAsync[TOutput](String name, Object input, IPipelineExecutionContext context)
ERROR SitecoreConnectionManager.Error: Message=The operation was canceled.|Trace=   at System.Net.Http.HttpConnection.SendAsyncCore(HttpRequestMessage request, CancellationToken cancellationToken)
   at System.Net.Http.HttpConnectionPool.SendWithNtConnectionAuthAsync(HttpConnection connection, HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken)
   at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken)
   at System.Net.Http.RedirectHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
   at System.Net.Http.DiagnosticsHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
   at System.Net.Http.HttpClient.FinishSendAsyncBuffered(Task`1 sendTask, HttpRequestMessage request, CancellationTokenSource cts, Boolean disposeCts)
   at Sitecore.Commerce.Plugin.Management.SitecoreConnectionManager.ProcessRequestAsync(CommerceContext commerceContext, String action, String method, ItemModel itemModel)

and in browser console enter image description here

Steps that I followed:

  1. I did changes in sitecorebizfx config.json for both (EngineUri and bizfxuri).

  2. I updated AllowedOrigins of wwwroot/config.json and launchsettings.json("COMMERCEENGINE_AppSettings__AllowedOrigins").

  3. I have updated the SQL database username, password, servername in Global.json, launchsettings.json, Plugin.SQL.PolicySet-1.0.0.json file.

  4. I have added the localhost URL in Sitecore.Commerce.IdentityServer.Host.xml file.

  5. I have changed the shopServiceUrl and commerceOpsServiceurl in Sitecore.Commerce.Engine.Connect.config file.

  6. Finally stopped the CommerceAuthoring site, restarted the IIS and clear the browser cache.

so can anyone help me to resolve this issue?

1
  • Double check the engine https url, Is 5000 the right default port for https? or should it be 5001? Sep 17 at 9:28
0

Have you bootstrap commerce engine after changing SQL connection setting in Plugin.SQL.PolicySet-1.0.0.json file? if not, then please do it and also do iisreset or apppool recycle of commerce engine after that.

1
  • Thankyou for your response ,it is very helpful
    – Nithya
    Sep 20 at 8:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.