I am working with Sitecore 10.1 and sitecore-jss 18.0. I am getting the error - Connection to your rendering host failed with a Not Found error. Ensure the POST endpoint at URL http://localhost:3000/api/editing/render has been enabled.

I have already verified the JSS editing secret in client and server side configuration. I also went through below solutions:

But as of now, it's not working. Did anyone face a similar issue? Any possible solution. Thanks a lot.

  • Got the same error with RenderingHost in docker a day ago, still investigating. Front site (RH) works fine, but not preview or EE ,
    – Daniil
    Commented Sep 16, 2021 at 11:46
  • The Not Found error can be misleading, could be another HTTP error. Anything in your Sitecore CM logs? Commented Sep 16, 2021 at 19:15
  • Did you figure it out @Roman Gupta ? I have the same error,
    – 9_9
    Commented Jan 19, 2022 at 15:09

1 Answer 1


I experienced the same issue, after some investigation, I found this setting below in


  <setting name="JavaScriptServices.ViewEngine.Http.JssEditingSecret" value="$(env:SITECORE_JSS_EDITING_SECRET)" />

So, you can define environment variable, or override/overwrite manually like here below:

  <setting name="JavaScriptServices.ViewEngine.Http.JssEditingSecret" value="mysecretkey" />

This solved my issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.