2

Sitecore Commerce 9.3

We are using the Address Editor component to store the users' addresses for account management. But logged in uses are not able to save addresses.

enter image description here

Getting this error in console on click on Save changes: /api/cxa/AccountAddress/AddressEditorModify

Errors: Address could not be added.

enter image description here

Getting these errors in logs, (not sure if they are related):

Exception: Sitecore.XConnect.XdbCollectionUnavailableException
Message: {
  "Message": "Operation failed: One or more dependencies failed",
  "ExceptionMessage": "One or more dependencies failed",
  "ExceptionType": "Sitecore.XConnect.Operations.DependencyFailedException",
  "StackTrace": null,
  "InnerException": {
    "Message": "An error has occurred.",
    "ExceptionMessage": "Store Error: Login failed for user '<projectName>_collectionuser'.. The error occurred while attempting to perform the underlying storage operation during 'Microsoft.Azure.SqlDatabase.ElasticScale.ShardManagement.StoreException: Error occurred while performing store operation

Source: Sitecore.Xdb.Common.Web
   at Sitecore.Xdb.Common.Web.Synchronous.SynchronousExtensions.SuspendContextLock[TResult](Func`1 taskFactory)
   at Sitecore.XConnect.Client.XConnectSynchronousExtensions.SuspendContextLock[TResult](Func`1 taskFactory)
   at Sitecore.XConnect.Client.XConnectSynchronousExtensions.Get[TEntity](IXdbContext context, IEntityReference`1 reference, ExpandOptions expandOptions, TimeSpan timeout)
   at Sitecore.Analytics.XConnect.DataAccess.XConnectDataAdapterProvider.LoadNonObsoleteContact(IXdbContext xdbContext, IEntityReference`1 contactReference, ExpandOptions expandOptions)
  

Exception: Sitecore.Analytics.DataAccess.XdbUnavailableException
Message: xDB unavailable
Source: Sitecore.Analytics.XConnect
   at Sitecore.Analytics.XConnect.DataAccess.XConnectDataAdapterProvider.ExecuteWithExceptionHandling[T](Func`2 func)
7
  • Seems like xDB issue, please check if your license is valid for xconnect and xconnect is working Oct 13 at 8:09
  • Thanks for the reply @GauravAgarwal. I've checked the licence, it is valid for xconnect and xconnect is working fine. Oct 13 at 8:56
  • can you see any error in Authoring logs? Oct 13 at 9:11
  • Yep, getting this error there: ERROR PipelineAbort:Customers.block.CreateCustomerAddress: Address for Customer Entity-Customer-c1053debb7944b71b7a39e5939216e48 is not valid. Oct 13 at 9:27
  • Try to pass CA in state and test please, because we got stateCode issue sometime Oct 13 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.