0

I'm trying to use the JSS CLI to deploy content and components to my local CM instance running in Docker, but with a different config file. Normally I run jss deploy files or jss deploy app and it works as expected, but if I try jss deploy files --config "./scjssconfig.test.json" I get prompted to configure a connection as if the config file doesn't exist.

Note the scjssconfig.test.json file is just the standard scjssconfig.json file with the name changed.

I've tried different combinations of paths for the config file - backslashes, foreslashes, fully specified, relative, moving the config file to another directory - but nothing works.

Has anyone gotten the JSS CLI to work with the --config switch?

2
  • Are you trying to deploy the scjssconfig.test.json file into Sitecore instance? Commented Nov 16, 2021 at 7:03
  • No I'm not trying to deploy/copy the scjssconfig.test.json file into Sitecore. Instead I want to have a different config file with slightly different settings (ex. different 'layoutServiceHost' for CI/CD in a cloud hosted environment.)
    – Dan
    Commented Nov 20, 2021 at 13:22

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.