We are having some performance issue when setting Datasources and Linking items in Sitecore 8.2. The test server just hangs when trying to expand a node in the dialog box. The CPU spikes to 100% and the Memory just keeps climbing until it reaches 100% as well. It runs like this for 5 – 10 minutes and eventually the server just kills the IIS process. I do not have this problem on my local development machine.

I’m pretty sure this is related to Facets. The reason is what I’m seeing in the search logs. Here are the entries in the search log once I try to expand a node when picking a Datasource:

My Local machine:

19052 10:58:04 INFO  Facet Search Query : +_datasource:sitecore +(+_latestversion:1 +_path:11111111111111111111111111111111)
19052 10:58:04 INFO  Facet Search Index : sitecore_master_index
19052 10:58:04 INFO  GetFacets : _templatename : +_datasource:sitecore +(+_latestversion:1 +_path:11111111111111111111111111111111) Filters: 
19052 10:58:04 INFO  GetFacets : culture : +_datasource:sitecore +(+_latestversion:1 +_path:11111111111111111111111111111111) Filters: 
19052 10:58:05 INFO  GetFacets : parsedcreatedby : +_datasource:sitecore +(+_latestversion:1 +_path:11111111111111111111111111111111) Filters: 
19052 10:58:05 INFO  Facet Search Took : 336ms

The Test CMS Server:

3916 09:35:15 INFO  Facet Search Query : +_datasource:sitecore +(+_latestversion:1 +_path:11111111111111111111111111111111)
3916 09:35:15 INFO  Facet Search Index : sitecore_master_index
3916 09:35:15 INFO  GetFacets : _templatename : +_datasource:sitecore +(+_latestversion:1 +_path:11111111111111111111111111111111) Filters: 
3916 09:35:16 INFO  GetFacets : culture : +_datasource:sitecore +(+_latestversion:1 +_path:11111111111111111111111111111111) Filters: 
3916 09:35:16 INFO  GetFacets : parsedcreatedby : +_datasource:sitecore +(+_latestversion:1 +_path:11111111111111111111111111111111) Filters: 
3916 09:35:17 INFO  GetFacets : __smallcreateddate : +_datasource:sitecore +(+_latestversion:1 +_path:11111111111111111111111111111111) Filters:

Notice how my local machine is not using __smallcreateddate as a Facet. Also notice that the test server never gets an entry related to how long the Facet search took. I found this article that I thought might fix the issue https://kb.sitecore.net/articles/576214. I did find and disable the Facet on the /sitecore/system/Settings/Buckets/Facets/Create Date Author item. I did this in both the Master and Core DBs and then published the folder. None of this seems to have helped. I still see these facets being used.

  • You may need to rebuild the entire 'sitecore_master_index' on the affected environment before you see any changes resulting from disabling that facet field. Why don't you try that, and see if that helps? – Chris Smith Nov 30 '16 at 18:29

you may need to migrate from lucene to solr. If you have more than 50K items to index then solr recommanded as best practice. analytics index causes to hike CPU utilization. Please turn off sitecore_analytics_index if you are not using analytics.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.