0

I am trying to build Sitecore 10.2 for containers on my Windows 11 system. Quite surprised when I got this message:

2017-10.2-20H2: Pulling from sxp/nonproduction/mssql-developer
image operating system "windows" cannot be used on this platform

I tried this on both the 2009 and ltsc2019 versions.

Is Windows 11 supported? Has anyone tried using Sitecore containers with Windows 11?

4
  • Did you just install docker? Did you switch from Linux to Windows containers in the context menu of the app? Nov 8 '21 at 23:30
  • Yes, I installed docker, and ran "docker/getting-started" to make sure everything was running properly. I went through the same steps on my Windows 10 VM running on top of Windows Server 2016, and did not encounter the error. Nov 8 '21 at 23:45
  • Windows 11 is not 20H2. You need to switch to hyperv isolation. Also, as stated above, you need to switch Docker to Windows mode, either via GUI or command line $Env:ProgramFiles\Docker\Docker\DockerCli.exe -SwitchWindowsEngine
    – Mark Cassidy
    Nov 9 '21 at 7:37
  • Thank you Mark. Unfortunately, I may not have been clear. Docker is running in Windows mode. It looks like the issue here is that Sitecore does not have images for Windows 11. Nov 9 '21 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.