I'm trying to spin up the following Sitecore environment using docker:


I've already run the Init.ps1 script that fills in all the variables, certificates, Sitecore license and so on... but when I run docker-compose up -d it says the following during the Nuget restore command: nuget restore error

Yesterday I've tried to fix that but I ended up messing with my machine, then I re-imaged it, and even doing that, with the machine all empty, the error persists. I couldn't find any relevant content about that on the internet. I don't know why the MSBuild auto-detection is trying to use that path that doesn't have the MSbuild installed.

Has anyone experienced a similar issue?

2 Answers 2


I've faced the same issue weeks ago and I fixed it by adding a google DNS ( on my docker settings as on the print screen below, try to do the same. Docker Engine Configurations


Besides solution suggested by Eduardo, you can also try disconnecting any VPN you are connected to and then running the script. I have seen similar error due to multiple reasons and disconnecting from VPN was one of the solutions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.