4

I have recently installed Docker Desktop for Windows, version 20.10.10. It is running in Windows Container mode. I am running Windows 10 Pro Version 20H2.

I am going through the Sitecore XP 10.2.0 Developer Workstation Deployment With Docker as per this this guide. I have downloaded the Sitecore 10.2 Container Deployment Package.

I have chose the ltsc2019 version of Windows, and XP0 topology.

I have successfully run the composer-init.ps1 script.

However, when I run docker-compose.exe up --detach, once the downloads are complete I receive the following error:

[+] Running 11/11
 - Network sitecore-xp0_default                     Created                                                        0.5s
 - Container sitecore-xp0-mssql-1                   Created                                                        0.1s
 - Container sitecore-xp0-solr-1                    Created                                                        0.1s
 - Container sitecore-xp0-mssql-init-1              Created                                                        0.1s
 - Container sitecore-xp0-solr-init-1               Created                                                        0.1s
 - Container sitecore-xp0-id-1                      Created                                                        0.1s
 - Container sitecore-xp0-xconnect-1                Created                                                        0.1s
 - Container sitecore-xp0-xdbautomationworker-1     Created                                                        0.1s
 - Container sitecore-xp0-xdbsearchworker-1         Created                                                        0.1s
 - Container sitecore-xp0-cortexprocessingworker-1  Created                                                        0.2s
 - Container sitecore-xp0-cm-1                      Created                                                        0.2s
 - Container sitecore-xp0-traefik-1                 Creating                                                       0.1s
Error response from daemon: Unrecognised volume spec: file '\\.\pipe\docker_engine' cannot be mapped. Only directories can be mapped on this platform

This seems to be related to this section of the docker-compose.yml:

volumes:
  - source: \\.\pipe\docker_engine
    target: \\.\pipe\docker_engine
    type: npipe
  - ./traefik:C:/etc/traefik

As a result, I am unable to start all of the Sitecore Containers. I would appreciate some direction on how to resolve this. I haven't been able to find much information on this error.

Thanks

4
  • Make sure your Docker is running in Windows mode.
    – Mark Cassidy
    Nov 19, 2021 at 7:37
  • 1
    Try changing source and target of volumes like this: source: '\\.\pipe\docker_engine\'. Add trailing slash and wrap with single quotes
    – Marek Musielak
    Nov 19, 2021 at 16:21
  • Thanks for your replies. @MarekMusielak I tried wrapping in single quotes, still had the same error. I've also tried from Powershell, console and bash in Administrator mode.
    – MickJ
    Nov 21, 2021 at 22:42
  • @MarkCassidy I am running in Windows mode.
    – MickJ
    Nov 21, 2021 at 22:46

3 Answers 3

7

You're running in Docker Compose V2 mode. Run the following command:

docker-compose disable-v2

Ref: https://stackoverflow.com/questions/68010612/error-response-from-daemon-unrecognised-volume-spec-file-pipe-docker-engi/70039471

1
  • That did the trick. Thank you!
    – MickJ
    Nov 22, 2021 at 5:41
3

After disabling the V2 mode docker-compose disable-v2 You might still get the same error, you run the following docker-compose command which will remove the cache and execute. which was helped for me!

docker-compose up -d --no-deps
2

I got the same error and the solutions for me was to add a \ to the end.

So:

- source: \\.\pipe\docker_engine\
  target: \\.\pipe\docker_engine\      

instead of:

- source: \\.\pipe\docker_engine
  target: \\.\pipe\docker_engine

Hope this helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.