1

I'm using Sitecore 9.3, Suddenly I faced an error that causes the CM server to be down, and I'm not able to access it.

I checked the logs and this is what I found:

ERROR  Error while instantiating agent. Definition: <agent type="Sitecore.Tasks.UrlAgent" method="Run" interval="00:15:00" patch:source="ProjectName.Web.config" xmlns:patch="http://www.sitecore.net/xmlconfig/"><LogActivity>true</LogActivity></agent>

This is the OOB Sitecore task, I don't know why this happen, we have many scheduled tasks, but all run as usual and this happened suddenly out of the blue.

0

This is an agent UrlAgent.

You can see its definition in the error:

<agent type="Sitecore.Tasks.UrlAgent" method="Run" interval="00:15:00" patch:source="ProjectName.Web.config"  xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <LogActivity>true</LogActivity>
</agent>

It doesn't have any url defined, that's why it cannot instantiate. There should be second parameter in your config:

<agent type="Sitecore.Tasks.UrlAgent" method="Run" interval="00:15:00">
  <param desc="url">https://<hostname>/sitecore/service/keepalive.aspx</param>
  <LogActivity>true</LogActivity>
</agent>
6
  • We already have this as a param: <agent type="Sitecore.Tasks.UrlAgent" method="Run" interval="00:15:00"> <param desc="url" role:require="PRD and ContentManagement"> hostname/sitecore/service/keepalive.aspx </param> </agent> Nov 19 '21 at 13:12
  • I need to mention also that this happens inconsistently, it's a random error, but recently it happens a lot. Nov 19 '21 at 13:26
  • In your comment it clearly says that param url is only set while it's PRD and ContentManagement. That role require should be moved to agent tag. Otherwise it will throw errors in every other environment. Nov 19 '21 at 14:04
  • Yes, you're right, but this happened on the PRD environment too. However I checked the showconfig.aspx, and I found that the url is not there, so this is the problem, but I have no idea why it's not there, because as per the rule, it should be there. Nov 19 '21 at 14:19
  • Are you sure that "PRD" is "role" Isn't it "env"? Shouldn't it be env:require="PRD" role:require="ContentManagement"? Nov 19 '21 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.