0

I am struggling with an issue that I can't get my head around of. I have a Sitecore 9.3 solution, for which I installed the Coveo for Sitecore module. The solution is multilingual, 3 languages (Netherlands, Belgium, German), from which the Belgium one was set to have the Netherlands as fallback.

Now, in order to have an extra field in the index, I created an IComputedIndexField (Sitecore.ContentSearch.ComputedFields). Checked the component in debug when indexing is triggered, works just fine for the Netherlands and German, but for Belgium, it is not triggered. The site works just fine for years now, having the language fallback set.

Does anyone have any ideas what might go wrong here or what I need to change?

5
  • 1
    Did you add below 2 settings you can find in the index element configuration? <index id="Coveo_master_index" ...> <enableItemLanguageFallback>false</enableItemLanguageFallback> <enableFieldLanguageFallback>false</enableFieldLanguageFallback> </index> Commented Nov 29, 2021 at 11:27
  • I see those settings in the Coveo.SearchProvider.config that I have. But shouldn't these 2 settings be set to true for that to have any effect? Commented Nov 29, 2021 at 11:35
  • 1
    Yeah these should be set to true, also follow this - answers.coveo.com/questions/16442/… Commented Nov 29, 2021 at 11:41
  • Yeah, If I set those to true works. Jesus. Very stupid of me not to check the config file for the coveo search provider. I saw that the Sitecore ones were set to true, but did not go deeper into the Coveo configs. Thank you very much. Commented Nov 29, 2021 at 11:44
  • I am adding this as a answer, please accept those then. Commented Nov 29, 2021 at 12:51

1 Answer 1

3

Add below 2 settings you can find in the index element configuration -

<index id="Coveo_master_index" ...>
  <enableItemLanguageFallback>true</enableItemLanguageFallback>
  <enableFieldLanguageFallback>true</enableFieldLanguageFallback>
</index>

This setting will enable language fallback for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.