0

Changes published to Sitecore 10.0.1 are visible in cd server but they are not reflected on site. Only after an app pool is recycled, changes reflect. How to make changes visible without app pool recycling.

4
  • 2
    This can be caching issue, are you clearing cache on publish:end event? Nov 30 '21 at 13:53
  • 1
    There isn't really enough information here to form an answer without first asking a series of questions. Posts like this are generally not accepted on the Sitecore Stack Exchange but are best taken to either Sitecore Slack or the Sitecore Community Forums.
    – Mark Cassidy
    Nov 30 '21 at 15:07
  • So, its making it to the web database but not showing on the site. It is most likely caching but based on how your application is coded, it could be multiple things Nov 30 '21 at 15:56
  • Assuming that you are talking about static content and given that recycling the app pool starts showing the content on site, it should be Sitecore caching the content. You should check if it is a specific rendering on the page which is being cached and then check its cache settings. Also, publish:end and publish:end:remote shall be patched to clear the cache.
    – Ghanendra
    Nov 30 '21 at 16:43
0

So, its making it to the web database but not showing on the site. It is most likely caching but based on how your application is coded, it could be multiple things:

Output caching - If that is turned on for your layouts or renderings, they may not be getting cleared properly. It is supposed to when you publish but you may want to check your pipelines to see if that is still in place

CDN - Do you have a CDN? Is it being cached there?

Enterprise cloud security - Do you have something like cloudflare or any other enterprise security system? These can cache pages as well.

Given it clears after app pool recycle, it can also be in the code where server memory cache is being used. Check that too.

Also, are there no-cache headers on these pages? If not, add them. This will prevent browsers from caching the pages, at the least.

0

For this kind of Issue, would recommend to uncheck caching on related component(Rendering Item) where facing issue while testing. After the change no additional step would required. For reference attached screenshot.

enter image description here

Only change/update Sitecore item, save and publish.
Try to render page, if still facing caching issue just to hard refresh (CTRL_Shift+R or CTRL+F5).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.