0

In our production, in Experience editor, while the item is in the final workflow state, to add new changes the next step is to lock and edit, once I "lock and edit" it, I see it's losing the item workflow state.

The same item with the same workflow has no issues in the dev and stage env's, Issue is only in prod, not sure what's causing it?

This is in the final WorkFlow state(Approved state) enter image description here

Item lost the workflow state after editing it in the final WF state in experience editor enter image description here

When I check the item, I see the state empty enter image description here

I tried adding the state manually in the item, but again after editing it in EE, it still repeats the same behavior where its looses the state after "lock and edit" in final wf state.

0

Please check that your workflow is selected in the Default workflow field of the template's __Standard values as described in this article. If it is not, there will be no workflow state selected by default when a new version of the item is created.

Update

If it happens only in the Experience Editor, then make sure your <site> definition in the config has enableWorkflow="true" as Experience Editor runs in the context of your website.

4
  • It is selected, as I mentioned this behavior is only in prod instance and that too in experience editor only, while I lock and edit it in content, I see it retains the state.
    – sns
    Dec 6 '21 at 6:01
  • If it happens only in Experience Editor, then make sure your <site> definition in the config has enableWorkflow="true" as Experience Editor runs in the context of your website.
    – Anna Gevel
    Dec 6 '21 at 19:30
  • Yeah will try that one, as this is in prod we need make sure it fixes the issue. We don’t have that attribute in the site definition in both dev and stg, and they work fine. So wondering if there is anything else that’s causing this issue
    – sns
    Dec 7 '21 at 2:11
  • To be clear, you need enableWorkflow enabled on the shell site, not "your" site.
    – jrap
    Dec 16 '21 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.