1

I'm trying to set up a commerce project on my local environment. I've created a new organization in Coveo, I made the necesary config changes, and for some reason, the products are not being shown in search results (only the articles).

I've rebuilt the solr and sitecore indexes in Sitecore, I did Refresh Commerce Cache in Content Editor, and nothing makes the product appear in the search result.

I've found the below error in CommerceMinions log files, but I didn't find any help on the internet.

00014 13:33:12 ERROR Pipeline completed with error
System.Exception: Error processing block: Catalog.block.InitializeItemIndexingView ---> System.NullReferenceException: Object reference not set to an instance of an object.
   at Sitecore.Commerce.Plugin.Catalog.InitializeItemIndexingViewBlock.<Run>d__3.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Sitecore.Framework.Pipelines.ReflectionPipelineBlockRunner.<InvokeBlock>d__2.MoveNext()
   --- End of inner exception stack trace ---
   at Sitecore.Framework.Pipelines.ReflectionPipelineBlockRunner.<InvokeBlock>d__2.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at Sitecore.Framework.Pipelines.BasePipelineBlockRunner.<Run>d__3`1.MoveNext()
00052 13:38:58 WARN CtxMsg.Warning.MinionProcessingSameEntities: Text=Minion 'Sitecore.Commerce.Plugin.Search.DeleteIndexDocumentsMinion, Sitecore.Commerce.Plugin.Search' didn't run. There is a minion processing the same type of entities in the 'Client_Name_Minions' environment running.
00042 13:39:14 ERROR ItemIncrementalIndexMinion-Incremental Item Indexing failed on prepare. Index Client_Name_master_index does not exists.
00042 13:39:14 ERROR ItemIncrementalIndexMinion-Incremental Item Indexing failed on prepare. Index Client_Name_web_index does not exists.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.