0

We upgraded a Sitecore site from 9.1 to 10.2. After the upgrade we installed the latest SPE. Everything works as expected except the SPE Reports submenu; it doesn't show, even for the admin user. We tried granting access to the Sitecore Client Authoring but that didn't help.

What debugging steps can we do to find the cause of this issue?

enter image description here

4
  • Which package did you install? (please share full name from github) Jan 19 at 22:22
  • @AlanPłócieniak Sitecore PowerShell Extension for Sitecore (Sitecore.PowerShell.Extensions-6.3 - IAR.zip) from Sitecore Downloads: dev.sitecore.net/Downloads/Sitecore_Experience_Accelerator/10x/…
    – TamerM
    Jan 19 at 22:31
  • Your question made me think about whether the SPE package version is different between Sitecore downloads (IAR) and github. It seems it is. I installed the one in github (without IAR) and it worked!! Please add your your comment as an answer
    – TamerM
    Jan 19 at 23:23
  • @TarmerM You will find the same IAR package on github as well. Please see my answer. If you have questions feel free to ask. IAR package could still work but additional work is needed. If you are using SXA you should stick with IAR. You could install IAR and re-run Content architecture cleanup script. Jan 20 at 13:22

1 Answer 1

1

Sitecore introduced Items as Resources (IAR) in 10.1

Starting with 10.2 it was also done for SPE (because SXA moved to IAR)

You might be wondering why - because it's necessary (SXA has a dependency on SPE). You can read more about it here

Here is where problems might occur

SPE is delivered right now as:

  • SPE-NORMAL - regular package - items will be stored in SQL - Sitecore.PowerShell.Extensions-6.3.zip
  • SPE-IAR - IAR enabled package - items will be stored as *.dat files - Sitecore.PowerShell.Extensions-6.3-IAR.zip

If you pick the wrong for your case, you will have problems (missing items, broken SXA scaffolding). It happens because item provider takes items from both sources (SQL, *.dat) which might led to unpredictable results.

Rules

Here are rules you should follow when upgrading/installing SPE/SXA for 10.2+.

  • NO SXA
    • FRESH INSTALLATION - install SPE-NORMAL or SPE-IAR - IAR is better for future upgrades (no leftovers in SQL) - I recommend it,
    • UPGRADE - install SPE-NORMAL - installing SPE-IAR is possible but you would have to cleanup items from SQL after that. With SXA it's done by upgrade script, you would have to do similar thing.
  • WITH SXA - for 10.2+ SPE-IAR is a must
    • FRESH INSTALLATION - install SPE-IAR before SXA,
    • UPGRADE - install SPE-IAR before you install SXA, then after you run SXA upgrade scripts (it will cleanup items for SXA and SPE form SQL so they are consumed from *.dat files)
1
  • This client had PowerShell installed before the upgrade mainly for reports without SXA. After the upgrade they wanted to install SXA too. Installing the IAR only didn't show the SPE Reports menu, only after installing the normal SPE package we were able to open the menu.
    – TamerM
    Jan 20 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.