2

I'm trying to do an XP0 install of version 10.2 using the SIA tool. I can't get past task 55. I get the following error every time.

Cannot open database "sc10_Xdb.Collection.ShardMapManager" requested by the login. The login failed.
Login failed for user 'sa'. 

Should I try a manual install? I was really hoping to use the SIA tool.

2
  • are you able to connect with this database using same "sa" credential in SQL Server Management Studio? Commented Feb 2, 2022 at 5:36
  • Yes. I can use the sa creds to connect in SSMS. The tool is able to create several db's before it hits this task and fails.
    – ajones
    Commented Feb 2, 2022 at 16:09

3 Answers 3

0

Interestingly, I ran into the same problem last week. This is what I found and how I solved it.

This is simply saying that it is trying to create databases in SQL server and doesn't have permission. You can look in your log file for more detail too.

Your server instance name or the password for that sa is wrong. Check that and once you get the right SQL server instance and password. It will work. FYI, in my case the SQL server was a named instance. Instead of (local) I had it as MySC10. Not sure if that matters, since I had wrong password.

Hope this helps.

2
  • Wouldn't the tool fail the verify step if the sa creds were incorrect?
    – ajones
    Commented Feb 7, 2022 at 16:52
  • No. It fails during the runtime. In my case, it went all the way to the last screen and run upto ( I think) script 45 or 52 something like that and it failed. The IIS items were installed and Solr was there except no DB ins SQL Server. Does this help?
    – Mhoque
    Commented Feb 8, 2022 at 19:11
0

Firstly verify if the SQL server is configured in Mixed Mode authentication when you were installing, If the installation is in Mixed mode, then check for the password for the user "sa". the below screenshot is where the error is in either the Instance name is wrong or the Password.

enter image description here

These are the possible issues for the Login failed issue.

Hope this helps!

Thanks, Yamini

1
  • It is configured for Mixed Mode auth. The install failed earlier because I had that wrong. I'm wondering if that failed install is causing me problems now.
    – ajones
    Commented Feb 7, 2022 at 16:54
0

In my experience, it's better to use pure SIF to install Sitecore. SIA does not surface all configurations in the GUI, which won't work for all use cases. In those cases, you'll need to make manual changes to the underlying scripts anyway, so again you may as well take the time to get a good boilerplate config set up with SIF that you can easily modify and reuse later.

I'd start by doing a full uninstall and manually check that everything has been uninstalled:

  • Databases
  • Hosts file
  • IIS
  • Certificates
  • Indexes
  • Services

It's also a good idea to restart your PC after you do this.

This could also be a problem with the underlying install scripts. Pay careful attention to the install logs and compare the successful database creates and authentications to this failed one. What exact connection string is being used to authenticate into sc10_Xdb.Collection.ShardMapManager? Does it match the same connection string as the other DBs?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.