2

I am going through the Developer Fundamentals training for Sitecore 10 on the SiteCore website. I created a solution prior to starting the training following my companies documentation. When creating that solution, I ran .\init.ps1, init2.bat, and docker-compose up -d. As I am going through the training, getting-started-template, I ran this command .\init.ps1 -InitEnv -LicenseXmlPath "<path to your license.xml file>" -AdminPassword "<your Sitecore administrator password>" My powershell appears to be stuck at this part, Created a new local CA at "C:\Users\theRestOfMyPath". I don't know if it is stuck because a certificate was already created the first time I ran the command for the other solution. Do I just open a new Administrator Powershell window and run the rest of the commands?

2 Answers 2

2

Firstly, you need to run the PowerShell in Admin mode and check the path of the license file. you need to add "license.xml". As shown in below screenshot. enter image description here

Hope this helps!

Thanks, Yamini

1

Yes, you have to open the powershell in Admin mode. Try to run the clean script from (clean.ps1) the folder first. It might be a folder deep (depending on how your folder is structured). This will remove everything from previous install. Then try again. I don't think your certificate is an issue here.

Do the following

Open Powershell in admin mode

  1. Go to that directory using
  2. cd [your directory path]/
  3. .\init [license path] (for me .\init “C:\sitecore\license\license.xml” )
  4. docker-compose build solution
  5. docker-compose build
  6. docker-compose up -d

Don't forget to clean after you do the docker-compose down. Just run that clean.ps1 script from the folder.

There are few things you should know that pre-requisite for docker. Supported version of Windows are Windows 10 pro or Enterprise with version 20H2 is most stable. Also you must have WSL2.

Here is a link that might help. http://mohammadhoque.com/?p=425

Hope this helps. Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.