0

When I click on "Lock and Edit" I am getting the following error:

Object reference not set to an instance of an object.


[NullReferenceException: Object reference not set to an instance of an object.]
Sitecore.Shell.Framework.Commands.CheckOut.Execute(CommandContext context) +297
   Sitecore.Shell.Framework.Dispatcher.Dispatch(Message message, CommandContext context) +209
   Sitecore.Shell.Applications.ContentManager.ContentEditorForm.HandleMessage(Message message) +1713
   Sitecore.Shell.Framework.Commands.MessageCommand.Execute(CommandContext context) +152
   Sitecore.Web.UI.Sheer.ClientPage.OnPreRender(EventArgs e) +547
   Sitecore.Shell.Applications.ContentManager.ContentEditorPage.OnPreRender(EventArgs e) +25
   System.Web.UI.Control.PreRenderRecursiveInternal() +113
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4297
4
  • can you check the item you are trying to lock and edit has the correct language and version?
    – phani
    Dec 5, 2016 at 15:05
  • Same error for multiple language versions.
    – ADH
    Dec 5, 2016 at 15:07
  • does this mean each language version you are editing has numbered version also?
    – phani
    Dec 5, 2016 at 15:23
  • I'm not sure what you mean. There is always a version 1.
    – ADH
    Dec 5, 2016 at 15:24

1 Answer 1

1

The error was fixed by adding a green check box for the "Workflow State Write" permission for each of the Writable workflow steps.

1
  • I had the same error and it was workflow related, but was solved by fixing the incorrectly entered "<r //>" in the lock field.
    – furtive
    May 19, 2022 at 22:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.