0

Getting error while setting up Solr 7.5.0, on SSL set step to add as root CA Script used:

https://gitlab.com/viet.hoang/workshop/blob/master/Scripts%20for%20Sitecore%209.1/install-solr.ps1

VM Server:

Trusting generated SSL certificate...

**Import-PfxCertificate : An internal error occurred. (Exception from HRESULT: 0x80090020)
At C:\sitecore\sc920_install\install-solr.ps1:93 char:9
+ $root = Import-PfxCertificate -FilePath $P12Path -Password $secureStr ...
+         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Import-PfxCertificate], COMException
    + FullyQualifiedErrorId : System.Runtime.InteropServices.COMException,Microsoft.CertificateServices.Commands.ImportPfxCertificate**

Local sever: Went fine same script on same step followed.

Trusting generated SSL certificate...
SSL certificate is now locally trusted. (added as root CA)
Resetting solr.in.cmd
Rewriting solr config
Installing Solr service
Service "solr-7.5.0" installed successfully!
Starting Solr service...

Any experience share would be appreciated.

2
  • 1
    Permissions issue?
    – Marek Musielak
    Commented Mar 16, 2022 at 7:30
  • Not sure, But work around is to create solr-ssl.keystore.p12 outside the server and transfer to server for installation. It depends and no clue. No all outside system created solr-ssl.keystore.p12 takes it up. strange error(permission or machine specific lock etc). tried couple of system file and among one worked. Commented Mar 17, 2022 at 2:43

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.