After migration from Solr to Azure Search I found the problem with a limited amount of fields for Sitecore indexes: core and master.

In all articles\answers was suggested disabling of indexAllFields property. But after this change rebuild stopped working. Error is:

Message: {"error":{"code":"InvalidRequestParameter","message":"The request is invalid.","details":[{"code":"InvalidScoringProfile","message":"The field named 'boost_2' referenced in the scoring function was not found in the index schema. Parameters: definition"}]}}

I found usage of this field in the Sitecore.ContentSearch.Azure.DefaultIndexConfiguration:

<scoringProfilesRepository type="Sitecore.ContentSearch.Azure.Models.ScoringProfilesRepository, Sitecore.ContentSearch.Azure">
        <scoringProfiles hint="raw:AddScoringProfile">
          <scoringProfile functionType="magnitude" interpolationType="linear" boostingRangeStart="1" boostingRangeEnd="10" cloudFieldName="boost_2" scoringProfileName="itemboost" scoringProfileBoostValue="10" constantBoostBeyondRange="false" />

So how could I make it work with reduced amount of indexed fields in sitecore indexes?

1 Answer 1


Finally I reverted indexAllFields setting to true back and tried to rebuild sitecore indexes. After rebuild I got 180 fields for sitecore_core_index.

Also I removed some unnecessary languages in system/languages and it slightly decreased amount of items (from 80000 to 18000) and fields ( from 180 to 110 ) in sitecore_core_index

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.