2

We have a website that has multiple domains for each language. For example, we might have example.com, example.ca, example.fr, child.example.ca, etc. However, the issue we're running into is with subdomains such as child.example.ca. We would like the beacon URL to pull from example.ca however we have found that while we can update the beacon script injection to pull from example.ca, the tracking will fail with a CORS missing allow permission since the hostname for SCBeacon will read example.com.

To fix this, we tried removing our config values from Sitecore.FXM.Config for FXM.Hostname. The result has been inconsistent. Sometimes the beacon URL for example.fr/bundle/beacon will return example.fr and sometimes it will return example.ca.

We have also tried setting the FXM.Hostname parameter in each site's SiteDefinition config, but has the same result.

What are some possible solutions to this problem? We are on Sitecore 9.2

1 Answer 1

1

You can take a look at this setting below with this config

\App_Config\Sitecore\FederatedExperienceManager\Sitecore.FXM.config:

  <!-- FXM BASE HOST DOMAIN
    When the Sitecore site and external sites are hosted on a common base domain but under different
    sub domains (and the sub domain isn't 'www'), then this setting should be set to the common base domain.  
    The following table best explains this:
    
    Site A                  Site B                    Base Host Domain
    shop.mysite.co.uk       jobs.mysite.co.uk         mysite.co.uk
    shop.mysite.co.uk       www.mysite.co.uk              -             (www is a special case and accounted for)
    www.mysite.co.uk        mysite.co.uk                  -
    shop.mysite.co.uk       mysite.co.uk                  -
    shop.mysite.co.uk       jobs.mysite.com               -
    mysite.co.uk            mysite.com                    -
  -->
  <setting name="FXM.BaseHostDomain" value="" />

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.