0

I am starting with Sitecore Forms. When I am going to create new form, I have a message on the top "You must have Sitecore xDB installed and robot detection in Experience Analytics configured to enable robot detection"

I have xDB installed and Added Ip addresses for robot to ignore. What else I need to do to make this message go away.

Also this is a VM that doesn't have any outside connectivity.

I can create new forms but robot detection checkbox is disabled. I am using Sitecore 9.3.

1 Answer 1

1

I got the same error couple of days back and in my case, it turned out to be: Analytics.AutoDetectBots was set to false. I just changed this setting to true.

Couple of more things to check:

  1. Check if you have a valid XDB license: How to check Sitecore.xDB.base in license file?

  2. Open <CM_Host>/sitecore/admin/showconfig.aspx and check below configs:

  • Xdb.Enabled should be set to true.
  • Xdb.Tracking.Enabled should be set to true.
  • Analytics.AutoDetectBots should be set to true.
  1. Ensure that your layouts contain the VisitorIdentification tag: @Html.Sitecore().VisitorIdentification()
1
  • Thank you. On mine I had Xdb.Tracking.Enabled to false. Setting that to true solved this for me.
    – Mhoque
    Commented Apr 19, 2022 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.