1

As a discovery task, I build a small Search page ("New Search") patterned after the Assets page, enabling Asset search functionality bit by bit to understand (and explain) how the Search component functions (adding facets, etc.). I ran into a snag demoing flyouts (also know as "Previews"). On my new page they display, but they don't have zoom enabled and don't display entity fields. I have not been able to identify why this works for Assets, but not my page.

My flyout with no text fields: Flyout display of a glass of orange juice without text fields to the right

Asset page flyout with text fields displayed: Flyout showing orange tree with fields displayed to right

My New Search page is defined like this (basic page as is Assets): enter image description here

My search component is defined like this: enter image description here enter image description here enter image description here

I can't identify a meaningful difference from the main Assets page that would account for the behavior difference. I've been able to add fields to the Assets flyout, so I don't believe latency is a factor.

Things I've tried:

  • Clearing cache, restarting the sandbox.
  • Enabling "Selection", "Enabling Track State" options on the Search component.
  • Changing the preview display option.

Content Hub version 3.4.6, sandbox with Fruitful snapshot.

1 Answer 1

1

The issue turned out to be that I created New Search as a "Basic" page, rather than an "Detail" page. I recreated it as a Detail page (for M.Asset):

enter image description here

Next I added a Search component with one field on the Flyout, and the field displayed: enter image description here

2
  • Thanks to Anna Bründel for pointing me in the right direction on Slack. Apr 26, 2022 at 16:47
  • Although this resolved the issue, it's worth noting that the Assets page is not set with an Entity Definition, so there must be some other way to resolve this issue. May 10, 2022 at 0:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.