2

I am trying to rebuild the search indexes through index manager, as an admin user. I am working on a Sitecore 8.0 instance from another developer, and I am not super familiar with Sitecore, myself.

I tried following the instructions below to rebuild the indexes:

  1. Log in to the Sitecore Desktop.
  2. Open the Control Panel.
  3. Click Indexing and then click Indexing Manager.
  4. In the wizard select the indexes you want to rebuild

The problem is that I am not able to see the "Indexing" section in control panel. Can anyone help me out?

  • 1
    Can you provide some more information? What have you tried so far? Are there any errors in the log files? As is stands this is a low quality question and will likely get voted down. If you can provide more detailed information, we may be able to help diagnose the problem. – Richard Seal Dec 7 '16 at 14:26
  • I am trying to reindex the search through index manager. The sitecre that I am working on is 8.0 which was done by other team member. I was following the instruction below that I found when I googled: 1. Log in to the Sitecore Desktop. 2. Open the Control Panel. 3. Click Indexing and then click Indexing Manager. 4. In the wizard select the indexes you want to rebuild ... I am wondering if any particular element I need to look in any configuration file. – Atit J Dec 7 '16 at 14:43
  • 3
    @AtitJ - I have translated the details that you provided in your comments into your question. In the future, try to include that same level of detail in your original question and you will find that you will get more upvotes, and more and better responses :) – Zachary Kniebel Dec 7 '16 at 14:58
  • Are you sure you are logged in as THE admin user? Did you login with username "admin"? If not, you may not be logged in as the actual admin. – DougCouto Dec 7 '16 at 15:04
  • 1
    Aha! Coveo! You may know this already but Coveo is an external search engine usually hosted on it's own server although, you can have Coveo running locally. You can also connect to Coveo Cloud if you have a subscription. Can you confirm you have a fully functional connection to your Coveo instance? This may be the root cause of your issue. – DougCouto Dec 7 '16 at 15:41
2

I may be a bit late to the party here, but I've just experienced a similar problem. On my development Sitecore 8.0 instance, a collection of things went wrong:

  • As described above, the "Indexing" section of the Control Panel vanished.
  • I started to get loads of odd "Null Reference" exceptions in the logs referring to aspects of analytics aggregation processing we had customised in the past.
  • While I could see all my indexes in the output of ShowConfig.aspx, the only index which appeared to work was "Quick search index" - everything else returned an "index not found" error if I tried to use it in code. And that lead to odd log errors from Sitecore code saying it could not find indexes either, such as "Social messages index could not be determined for master database. Messages root path: /sitecore/social/Messages. Please check indexes configuration."

After a lot of banging my head on the table, and diffing config files, I found a difference between the old and new states: The setting BucketConfiguration.ItemBucketsEnabled in the Sitecore.Buckets.config file was set to false. Returning that to true fixed all the problems I was seeing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.