0

Installing Sitecore 9.3 on-premise for myself, a developer.

First time installing Sitecore. I've gone through the documentation and searched on Google, stack exchange, the Sitecore community, etc. for an answer and haven't found anything even close to what I am seeing.

During the "Validate" step in the UI driven installation, I get a red "X" next to "WDP files". I kind of understand what WDP files are, but the error is still baffling. I passed all requirements up to this point and I don't know how to get past this.

Installation logs do not contain any errors.

3
  • Could you share screenshot of the error that you are getting? May 20, 2022 at 22:44
  • Yes, you need to provide more information, maybe a screenshot or the step where this is failing. May 21, 2022 at 17:03
  • Something was missing/corrupt from my installation files. I re-downloaded and was able to install. Thanks to all for comments and answers.
    – T H
    May 24, 2022 at 17:20

3 Answers 3

1

If you faced this error:

enter image description here

The reason for this error is that for some unknown reason you don't have all WDP files within your installation folder. Sitecore needs it to install the instance. All WDP files have an extension of .scwdp.zip.

To fix your issue, try downloading again the installer from: https://sitecoredev.azureedge.net/~/media/A1BC9FD8B20841959EF5275A3C97A8F9.ashx?date=20191213T115458

or

https://dev.sitecore.net/Downloads/Sitecore_Experience_Platform/93/Sitecore_Experience_Platform_93_Initial_Release.aspx, then select Graphical setup package for XP Single.

or if you're copying the installation folder from someone/somewhere pay attention if you copied all files, sometimes the Windows or the Antivirus blocks or excludes files without you realizing.

So make sure your installation folder contains 5 .scwdp.zip like the image below:

enter image description here

Hope it helps you!

2
  • I downloaded again and ran the install. I was able to get past the error. Thanks. Doesn't explain why I got the error or what it means, but I'm on my way.
    – T H
    May 23, 2022 at 13:53
  • Nice, you're welcome! Perhaps some file was corrupt. Usually, this error indicates something wrong in your files. May 23, 2022 at 14:46
1

Can you please try downloading Graphical setup package for XP Single for
Sitecore 9.3 from below url as shown in below screenshot https://dev.sitecore.net/Downloads/Sitecore_Experience_Platform/93/Sitecore_Experience_Platform_93_Initial_Release.aspx

enter image description here

0

Sometimes it's simply caused by too long paths on Windows (max path limit is 260 characters). I once faced the same issue when I extracted the Sitecore installation package that way that it created an additional folder with a long package name inside - so I had something like Sitecore 9.3.0 rev. 003498 (Setup XP0 Developer Workstation rev. 1.1.1-r4)\Sitecore 9.3.0 rev. 003498 (Setup XP0 Developer Workstation rev. 1.1.1-r4)\installation files here. The installation showed red x next to WDP files because paths to some of the WDP packages exceeded 260 characters. Once I moved the files one level up, the installation went through without problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.