3

We need to create workflow Approver Role without write access right.

We are trying to setup the roles for workflow. This has four states.

Designer State - First or draft State

Reviewer State - Intermediate State

Publish State - Intermediate State

Approved - Final with auto publish state

We have created three custom roles.

Designer - This will create and edit item and send it for review.

Reviewer- This will approve and send the item to publisher or reject to designer. This user is only for approving but not for anything purpose (e.g. editing, creating etc.).

Publisher- Can publish the item as well as create/edit item or send it to next state.

Now problem is that this does not show the items in workbox for reviewer role user without write access for editor.

What can we do for reviewer role?

  • Hello @Aman, i have the same requirement, did you manage to find a solution for the write access problem? – AmiraElEwady Jul 10 '19 at 11:00
3

It is expected behavior. If you are changing workflow, it actually means editing the item. So for Reviewer role you need to have

'workflowCommand:execute' access right for appropriate workflow state;

'item:write' to be able changing the workflow which in fact actually editing the item.

You may try restricting access for Reviewer role to buttons, which allow items editing. you may try restricting Read access rights to the following items with subitems (core database):

/sitecore/content/Applications/Content Editor/Context Menues
/sitecore/content/Applications/Content Editor/Ribbons/Ribbons/Default/Home
/sitecore/content/Applications/Content Editor/Ribbons/Ribbons/Default/Publish
/sitecore/content/Applications/Content Editor/Ribbons/Ribbons/Default/Versions
/sitecore/content/Applications/Content Editor/Ribbons/Ribbons/Default/Configure
/sitecore/content/Applications/Content Editor/Ribbons/Ribbons/Default/Presentation
/sitecore/content/Applications/Content Editor/Ribbons/Ribbons/Default/Security
/sitecore/content/Applications/Content Editor/Ribbons/Ribbons/Default/My
/sitecore/content/Applications/Content Editor/Ribbons/Ribbons/Default/Developer
/sitecore/content/Applications/Content Editor/Ribbons/Chunks/Write
/sitecore/content/Applications/Content Editor/Ribbons/Chunks/Proofing
/sitecore/content/Applications/Content Editor/Ribbons/Chunks/Locks
/sitecore/content/Applications/Content Editor/Ribbons/Chunks/Schedule
/sitecore/content/Applications/Content Editor/Menues/Versions
/sitecore/system/Settings/Workflow/Check in

Additionally, you may try controlling Ribbon buttons visibility via the pipeline in the web.config file.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.