2

Whenever I run sitecore_master_index or sitecore_suggested_test_index on Sitecore 9.0.1, I see the below errors in the Crawling logs. I cannot find the item {7FBCE76B-D04A-42C9-8CB2-D61BFA202879} in the Content Tree either.

Any suggestions please?

Exception: System.InvalidOperationException
Message: Item template not found.
Source: Sitecore.ContentSearch
   at Sitecore.ContentSearch.IndexOperationsHelper.GetAllTemplates(Item item)
   at Sitecore.ContentSearch.AbstractDocumentBuilder`1.<>c__DisplayClass55_0.<AddComputedIndexFieldsInParallel>b__0(IComputedIndexField computedIndexField, ParallelLoopState parallelLoopState)```

1 Answer 1

2

It looks like you had a template which was somehow removed from Sitecore later.

Or alternatively, one synchronized an item without synchronizing the template, and now you have an item in your database which has no template.

Solution? Run the following script on your SQL database:

SELECT TOP (1000) [ID]
      ,[Name]
      ,[TemplateID]
      ,[ParentID]
  FROM [Items]
  WHERE [TemplateID] = '{7FBCE76B-D04A-42C9-8CB2-D61BFA202879}'

and for any [ID] from the result set open item in dbbrowser tool:

`https://yourhost/sitecore/admin/dbbrowser.aspx?db=master&lang=en&id=[ID]`

Delete that item.

If necessary, change database from master to e.g. web in the url above.

1
  • Thanks @Marek. The solution works :) May 24 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.