1

I'm having a problem on our site setup with Sitecore 10.2, Sitecore Headless Services 19.0 and SXA. GraphQL integrated isn't returning data correctly on our CD site, it is only working properly on the content management (CM) server - though it is also not returning data on the layout service API (/sitecore/api/layout/render).

The problem is that no data is being returned to the page/in the API. On the pages, when accessed from the CM (e.g. page edit mode, but also with sc_mode), the data from GraphQL queries comes through as expected. Using the GraphQL playground (/sitecore/api/graph/edge/ui), the GraphQL statements function as expected (the GraphQL playground is only accessible on the CM server). GraphQL connected is working properly across all modes/servers.

I've tried different pages, different renderings, and modifying the NextJS components to no avail.

1 Answer 1

1

I'm not sure if this will solve your issue as you mention it is working on the CM - but we had an issue with integrated GraphQL on an 10.2 headless setup including SXA.

The issue was solved by this kb: https://support.sitecore.com/kb?id=kb_article_view&sysparm_article=KB1000658

Might seem completely unrelated but it solved the problem for us. After deleting the config file modules/sxa/z.layout.service/layout.service.config the integrated mode worked.

If this doesn't fix, you should compare your config files between CM and CD to check for differences - and also check if there are no GraphQL related parts that get changed by the environment patching.

1
  • Deleting that config using the dockerfile line in your article worked! Thanks!
    – James G.
    May 26, 2022 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.