0

I have deployed our Application on PROD CM and CD instance on the Azure PAAS and the instance is working fine. When I try to log in to the CM instance, I can log in, but instead of redirecting me to the Sitecore Content Editor it's throwing me an error 500 - The request timed out. The webserver failed to respond within the specified time.

After logging into the CM site, the following error is displayed: 500 - The request timed out. The web server failed to respond within the specified time

After login into the CM instance: enter image description here

enter image description here

I have verified the AllowedCorsOrigins and Redirect URL in the identity server and CM instance in both Sitecore.IdentityServer.Host.xml and Sitecore.Owin.Authentication.IdentityServer.config respective files and all are correct.

The same code and deployment work perfectly with the Pre-PROD environment on the Azure PAAS.

Sitecore Version 10.2

1
  • Did you check Chrome Dev Tools console for any errors/issues? May 30 at 14:00

1 Answer 1

0

After analyzing data from a period of time where there was an issue with slow /identity/externallogincallback requests.

Based on the Availability and performance section in the Azure portal, I see slow requests to /identity/externallogincallback gone after a few days (approx 7 days): enter image description here

Also, I see 3 5xx errors during this period, most likely these errors are related to /identity/externallogincallback request timeout: enter image description here

After that verified the Master DB DTU and it was returning 100% spikes all time so I have increased it to 50 DTU. enter image description here

Hope it helps to analyze the issue if someone faced the same.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.