1

I was setting up one of the sites in my local and I am facing the Unknown Connection String. Name: 'core' error when I try to browse the site. Have imported the databases into my local SQL management studio.

enter image description here

Here is the connectionstring file :

 <add name="core" connectionString="Data Source=xxx;User ID=sa;password=welcome1@;Database=sitecore-core-2022-3-15"/>
        <add name="master" connectionString="Data Source=xxx;User ID=sa;password=welcome1@;Database=sitecore-master"/>
        <add name="web" connectionString="Data Source=xxx;User ID=sa;password=welcome1@;Database=sitecore-master"/>
        <add name="custom" connectionString="Data Source=xxx;User ID=sa;password=welcome1@;Database=sitecore-custom"/>
        <add name="web2" connectionString="Data Source=xxx;User ID=sa;password=welcome1@;Database=sitecore-master"/>

The log is not generating any error related to the above issue it only says as below enter image description here

Can anyone please suggest how do I need to resolve this issue?

Thanks

8
  • Can you check this file \App_Config\Sitecore\CMS.Core\Sitecore.CoreDatabase.config and compare with vanilla instance or any old solution you have on your local? Jun 7, 2022 at 14:18
  • Try validating the XML of the entire config file. Also try wrapping your password in single quotes in case it has a reserved character. Also try restoring the vanilla Web.config to see if that helps. Jun 7, 2022 at 20:11
  • @Sumit Bhatia i don't see that config file in my local neither in the vanilla instance
    – Vinaya
    Jun 8, 2022 at 6:20
  • @Vinaya Please specify your Sitecore version Jun 8, 2022 at 6:25
  • @Sumit Bhatia sitecore version is 8.2 revision 170614
    – Vinaya
    Jun 8, 2022 at 7:22

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.