1

We have a few templates in our project which use the General Link field type. We're finding them unpredictable.

In our Staging environment, by clicking the Insert Link field to create a link to another content item the Insert Link dialog is displayed. This allows us to navigate the content tree to select the item to be linked to. However, upon selecting the desired target we don't get the Link Details display, and on clicking the Insert button to commit the selection and close the dialog, nothing happens. In our Development (pre-Staging) environment we can't navigate the content tree at all. But on some of our local development machines, it works fine.

The only telltale hint we've found thus far is a JavaScript error in the browser developer tools in the Staging environment indicating a function called insertInternalLinkResult() isn't defined. This seems to indicate that one or more of the implementing Sitecore files may be missing or out of date, but we're unable to track it further than that. Has anyone else had similar problems with this field type, or has other pertinent insights to this problem?

2
  • Did you upgrade Sitecore? Commented Jun 9, 2022 at 16:04
  • You'd probably be better off asking this in the Sitecore Slack Channel - this would likely need some debugging and discussion, which is not the best format for SSE
    – Richard Seal
    Commented Jun 9, 2022 at 17:59

1 Answer 1

0

I believe the function insertInternalLinkResult() is defined in

Sitecore/shell/client/applications/dialogs/insertlinkviatreedialog.js

Please can you confirm the file hasn't been removed during any upgrade process? If missing add from the vanilla install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.