0

When making any edits to the cshtml files. I get a bad gateway error on CD and on CM I get a The operation has timed out error. So far the only way to get the sites working again, is doing a docker-compose down and then docker-compose up -d. Then the site responds correctly and also shows the change I made too.

operation has timed out.

badgateway

1
  • I have also tried to downgrade to docker 4.6.1 and rebuild my images and the same thing happens.. I have tried 3 different docker examples and the same issue happens... When I look at the rendering logs this is the error I get... C:\Program Files\dotnet\sdk\3.1.420\Microsoft.Common.CurrentVersion.targets(4651,5): error MSB3021: Unable to copy file "C:\solution\src\Feature\Navigation\rendering\obj\container\Debug\netcoreapp3.1\BasicCompany.Feature.Navigation.Views.dll" Jun 21, 2022 at 12:53

1 Answer 1

0

Based on this post, it's a bug in Docker Desktop for Windows. Running docker-compose restart rendering cm before you refresh the page will allow it to load properly. I know this doesn't exactly "fix" the issue, but it seems to work.

1
  • running that command does bring it up much faster.. so at least its something to work with thanks.. hopefully this bug gets fixed sometime soon. Jun 21, 2022 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.