0

We have set up Sitecore 10 environment. It was working properly but suddenly it stopped authenticating and started giving error.

We are getting below error everytime we try to log in

Login failed for user 'securityuser'

is there anything we need to check in Sitecore Core DB for this user?

Thanks in advanced.

3
  • 1
    it looks like your securityuser is not able to login into database, could you please check your connection string and make sure the password for securityuser is working fine? Jul 18, 2022 at 12:24
  • 1
    Or try to change user name as "sa" and the password, it should work Jul 18, 2022 at 12:33
  • perfect both the solution worked. Problem is with securityuser. Not sure what has happened to the user account. Thanks for the help. Jul 18, 2022 at 13:38

1 Answer 1

1

You can try the following things, to make it work.

  1. Update your password: Using the SQL management studio you will need to connect to the database server and then run the below command to modify the password.

    ALTER USER securityuser WITH PASSWORD = 'your-password'

  2. Add role to a user: You need to execute sp_addrolemember procedure with 'db_owner' and 'securityuser' parameters like that:

    EXEC sp_addrolemember 'db_owner', 'masteruser'

Either of the ones might resolve your issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.