Our customer is creating a large body of new bucketed content (using a new template) below a parent item (which is also new). In order to publish all this at once, they're leaving the parent unpublished until they're ready to reveal all of this. In the meantime, they'd like to be able to run the default bucket query on the the parent in the Content Editor to view all the new children, but when we try to do this only the parent item is returned. Is this a consequence of parent not being published, or have we missed some necessary action or setting? (May be worth noting: we've compared settings with other parents and templates - which search successfully - in the same part of the content and found nothing obvious.)

Update I may have just blundered into the problem: the index definition updates for the new content type are part of a code update which hasn't been deployed to the subject environment yet. I'll have to take direction about whether to deploy the index definition updates ahead of the rest of the code or not.

  • Have you tried reindexing the bucket tree? (Developer tab => Reindex tree) It should have nothing to do with publishing, as searches in content editor are performed on master database (sitecore_master_index).
    – Kamil C
    Jul 23, 2022 at 9:12
  • I guess I should have mentioned, our search system isn't using Solr; just Lucene. (Maybe someday....) Jul 25, 2022 at 20:13
  • Could you please add the Sitecore version as well? Jul 26, 2022 at 7:41
  • Sitecore version 8.2 Jul 26, 2022 at 13:57

2 Answers 2


It is not returning you child items of that particular parent item because child items are not indexed you can try below thing:

  • Go to control panel then indexing manager (as shown in below screenshot) then index particular index either Sitecore_master_index or if you created any custom Sitecore index for these items.

enter image description here

  • Another way from developer tab you can select index and re-index selected node as shown in below screenshot.

enter image description here

Then after you can check result count as well by running Solr query in Solr.

Hope this help.


Bucket search is dependent on indexing and does not have any dependency on publishing. But based on the publishing strategy for your Content Management server, indexing can depend on your publishing. I would suggest you two options here to see the results in the content editor -

  • Manual Reindex - You can perform manual reindex using the control pannel or the content editor's developer tab. Where you can rebuild all the indexes or a particular index or from the developer's tab re-index the tree.

    enter image description here

    By default, Sitecore hides the Developer Tab. In order to activate the Developer Tab, you need to right-click on the Content Editor Ribbon and select the Developer option from the list. Please see the below screenshot.

    enter image description here

    You need to select the parent item and perform the re-index tree for the node.

  • Update the indexing strategy on CM - Since you want to see the changes on the master database without publishing you can change the indexing strategy for this. you can choose an indexing strategy based on your requirement but below are two which you can choose -

    • Synchronous strategy - This strategy is the index update strategy closest to real-time. It is also the most expensive strategy in terms of CPU and I/O.
    • Intervalasynchronous strategy - Similar to Synchronous but need to specify the frequency of the strategy trigger with the interval parameter. This strategy is triggered by a time interval and not the OnPublishEnd event. It uses the EventQueue table of the source database. The source database is specified by the database parameter of the strategy.
  • My thanks for everyone's inputs. I've now tried re-indexing the tree and rebuilding sitecore_master_index. Unfortunately none of these actions seem to have helped. Jul 25, 2022 at 15:52
  • @RonRitchie are you facing any errors? the content editor uses sitecore_master_index for searching and it is not dependent on publishing if you are manually doing a rebuild index. Could you please do a search in Solr UI directly to validate whether your new items are indexed there or not? Jul 25, 2022 at 16:07
  • Sorry, I should have mentioned: we're not using Solr, just Lucene. Looking at the log for a quick Re-Index Tree command, It doesn't seem to be throwing errors or raising exceptions but it's also not finding any content to process. Jul 25, 2022 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.