0

I'm trying to setup the code solution & the Sitecore instance in docker for a helix example, following this article.

https://github.com/Sitecore/Helix.Examples/tree/master/examples/helix-basic-aspnetcore

After running the docker-compose up -d, it looks like it downloaded the images. I can see them in the Docker. But there are no containers.

I would like to see the Sitecore instance and the website to learn Headless development using ASP.NET Core Rendering SDK.

Should I manually create containers? Did the docker-compose step not run correctly?
How do I proceed from here.

docker-compose up -d status:
enter image description here

enter image description here

enter image description here

UPDATE:

I have unchecked "User Docker Compose V2" and then ran again. It now fails with this error:

ERROR: for traefik Cannot start service traefik: failed to create endpoint basic-company-aspnetcore_traefik_1 on network basic-company-aspnetcore_default: failed during hnsCallRawResponse: hnsCall failed in Win32: The process cannot access the file because it is being used by another process. (0x20) ERROR: Encountered errors while bringing up the project.

enter image description here

4
  • 1
    Hi, your first screenshot shows there are some errors. Can you please check that you're running Windows containers in Docker? Also, double check that 'Use Docker compose V2' is disabled in Docker settings. Jul 25, 2022 at 11:48
  • @MiguelMinoldo Did that and ran compose command again. That seems to solve some issues but now it keeps failing with the traefik error.
    – sukesh
    Jul 25, 2022 at 11:55
  • 1
    Please check IIS is stopped in your host Jul 25, 2022 at 11:58
  • try restart vmcompute service. Jul 25, 2022 at 12:05

1 Answer 1

0

Stopping IIS worked for me.

These are the steps I had to do before following the instructions here: https://github.com/Sitecore/Helix.Examples/tree/master/examples/helix-basic-aspnetcore

#1 - run smc -stop in Run dialog to stop Symantec.
#2 - Then stop IIS in powershell with iisreset /stop.
#3 - Start Docker and uncheck Use Docker Compose V2 in Settings. Apply the changes & Restart Docker.

1
  • 1
    Hi @Qwerty, glad to see it worked. Thanks for switching my comments as the answer to fix your issue. Jul 25, 2022 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.