We have installed Sitecore Publish Module(3.1.1) for Sitecore 9.0.1 version, except for re-publish everything is working.

On publishing wizard not getting re-publish option and in recent jobs when we click any publish complete item able to see re-publish. When we click on re-publish item versions affected showing zero(0). We understood republish option not working using Sitecore Publish Module.

Please help us how to fix this issue.

  • Are you talking about the re-publish everything option? without taking care of anything publish all the items again? Aug 19, 2022 at 10:08

1 Answer 1


As per the Sitecore Publishing Service documentation, the Sitecore Client Publishing and the Sitecore Client Advanced Publishing roles do not grant access to the full republish functionality.

When you install the Publishing Service module, the Publishing Service Administrator role is created. This role has full access to the Publishing Service features, including the full republish functionality on the Publishing Dashboard.

To avoid security permission conflicts, ensure that users that must be able to perform a full republish are members of the Publishing Service Administrator role and not members of the Sitecore Client Publishing or Sitecore Client Advanced Publishing roles.

For more information use the below link and click on Installation Guide to download the PDF.

Sitecore Publishing Service 3.1.1 Installation Guide

Then jump onto page 30 (section 4.5 - security) from the index.

Hope this answer your question.

  • I have include Publishing Service Administrator role still am not able to see re-publish option on item publish option. @Sumit
    – Reddy
    Aug 19, 2022 at 4:15
  • Did you go through the document I have shared? Aug 19, 2022 at 4:22
  • Have gone through that document, what ever steps there i followed but didnt help me
    – Reddy
    Aug 19, 2022 at 4:27
  • Did you change in the config file given in the step 4.5.1? Aug 19, 2022 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.