1

I am getting below error when connecting the TDS with Sitecore instance.

Sitecore version: 10.2
TDS version info: 6.0.0.36
Connection Test Pass: TDS service files are correctly installed.
Connection Test Failure: Failed to complete test.
Exception The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (text/xml; charset=utf-8). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '<!DOCTYPE html>
<html>
    <head>
        <title>Parser Error</title>
        <meta name="viewport" content="width=device-width" />
        <style>
         body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;} 
         p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}
         b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
         H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }
         H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
         pre {font-family:"Consolas","Lucida Console",Monospace;font-size:11pt;margin:0;padding:0.5em;line-height:14pt}
         .marker {font-weight: bold; color: black;text-decoration: none;}
         .version {color: gray;}
         .error {margin-bottom: 10px;}
         .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:pointer; }
         @media screen and (max-width: 639px) {
          pre { width: 440px;'. (ProtocolException):

Server stack trace: 
   at System.ServiceModel.Channels.HttpChannelUtilities.ValidateRequestReplyResponse(HttpWebRequest request, HttpWebResponse response, HttpChannelFactory`1 factory, WebException responseException, ChannelBinding channelBinding)
   at System.ServiceModel.Channels.HttpChannelFactory`1.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)
   at System.ServiceModel.Channels.RequestChannel.Request(Message message, TimeSpan timeout)
   at System.ServiceModel.Dispatcher.RequestChannelBinder.Request(Message message, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]: 
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at HedgehogDevelopment.SitecoreProject.VSIP.SitecoreConnector.TdsServiceSoap.Version(VersionRequest request)
   at HedgehogDevelopment.SitecoreProject.VSIP.SitecoreConnector.TdsServiceSoapClient.HedgehogDevelopment.SitecoreProject.VSIP.SitecoreConnector.TdsServiceSoap.Version(VersionRequest request)
   at HedgehogDevelopment.SitecoreProject.VSIP.SitecoreConnector.TdsServiceSoapClient.Version()
   at HedgehogDevelopment.SitecoreProject.VSIP.ProjectTests.AccessGuidTest.<>c__DisplayClass3_0.<Execute>b__1(String key)
   at HedgehogDevelopment.SitecoreProject.VSIP.Utils.Support.CallServiceWrapper[T](TdsServiceSoapClient client, SitecoreProjectNode project, Func`2 clientCall)
   at HedgehogDevelopment.SitecoreProject.VSIP.ProjectTests.AccessGuidTest.Execute()
   at HedgehogDevelopment.SitecoreProject.VSIP.Dialogs.BuildTestDialog.RunTests()


Inner Exception Details:
Exception The remote server returned an error: (500) Internal Server Error. (WebException):
   at System.Net.HttpWebRequest.GetResponse()
   at System.ServiceModel.Channels.HttpChannelFactory`1.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)
Connection Test Finish: 2022-08-23 04:53:08
2
  • did you check your Sitecore instance url is correct? If yes and uncheck test checkbox save it and then check it and save it, then try. Commented Aug 23, 2022 at 9:51
  • run visual studio as administrator and try the test again, any permission related issues will be resolved Commented Aug 24, 2022 at 22:19

3 Answers 3

0

Try below things

  1. Sitecore Web URL is correct
  2. Sitecore Deploy Folder Path is correct
  3. Try to uncheck checkbox under Sitecore Access Guid and check again

After all these steps make sure your Sitecore instance is up and running and then click on Test button.

Hope this help.

0

There can be multiple issues with connectivity. I will suggest a few more solutions here.

  • Go to your Sitecore webroot (published) folder and check the permission. And try to give permission to everyone to make sure that the issue is due to this.

  • Or Delete the _Dev folder in the website root and reinstall the TDS connector

Try them and update if you still get the error.

Hope this helps.

0

This exception is being thrown because the content type of the response message does not match the content type of the binding. This can occur for a number of reasons, such as the server sending a response with an unexpected content type, or the client expecting the wrong content type

You can verify if the TDS service is working by going to the URL "www.yourdomain.com/_dev/TdsService.asmx"

I have encountered a similar issue with a redirect rule that converted the URL to lowercase, I recommend checking the redirect rules to ensure they are not altering the response in unexpected ways.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.