1

I want to enable to language Fallback for particular Item. I have performed the all the standard steps

  1. Enabling the language fallback option on sitecore

Standard values 2) Checked the settings on the config file and set the values to true

On sitecore when i got the other language it says "No version exists in the current language. You see a fallback version from 'en' language.

enter image description here

Navigate to the original item.
Add a new version."

But when i got the website and see the EN language works fine but the other language is throwing a 404 error.

Please help me if i am missing any steps here.

Regards, S.Harshavardhan

2
  • Are you using Sitecore with SXA? Sep 5, 2022 at 11:27
  • No We are not using SXA Sep 5, 2022 at 11:32

2 Answers 2

1

Field level language fallback enables you to specify on a field-to-field basis, which field values should be localized and which field values should fall back to another language.

Field level language fallback is disabled by default, so you must enable it on each relevant website and on the template field definition item.

Follow these steps to enable the feature on your Sitecore instance:

  1. Enable Field level language fallback on the desired sites in Sitecore configuration. This change can be done within /App_Config/Include/Sitecore.LanguageFallback.config or any other custom config include file.

     <site name="shell">
          <patch:attribute name="enableFieldLanguageFallback">true</patch:attribute>   </site>  
      <site name="website">
          <patch:attribute name="enableFieldLanguageFallback">true</patch:attribute>   </site>
    

enter image description here

  1. Specify the fallback language rules. The fallback language specified on a language definition item in content tree under the /sitecore/system/Languages item. For each language that has to be enabled for fallback, make sure the Fallback Language field on that language definition item points to the desired target language.

enter image description here

  1. Finally, you need to enable Field level language fallback for those fields you'd like to have this feature enabled. There are two checkbox fields that enable this feature:

Enable field level fallback This is a shared field that is used to enable language fallback for all the language versions of the current field. This applies to the all the currently available language versions of the field and any new language versions that you create. In other words, if you require that a certain fields need to be enabled for fallback only in certain languages, the Enable versioned field level fallback field should be used.

Enable versioned field level fallback This is a versioned field used to enable language fallback for only the current language version of the field. To allow different fallback settings for the same field in different languages (versioned fallback), in the /App_Config/Include/Sitecore.LanguageFallback.config file, the following configuration setting must be set to true.

<setting name="LanguageFieldFallback.AllowVaryFallbackSettingsPerLanguage" value="true" />

For more information follow this - https://support.sitecore.com/kb?id=kb_article_view&sysparm_article=KB0111331

0

On all the individual items or item templates where you want to use language fallback, you must enable item-level fallback

To enable item-level fallback:

  • In the content tree, navigate to the relevant item.
  • To enable language fallback on a template, navigate to the relevant template and click the _Standard Values item.
  • On the Content tab, in the Advanced section, select Enable Item Fallback.

Follow this document for more details.

https://doc.sitecore.com/xp/en/developers/92/sitecore-experience-manager/enable-and-set-up-language-fallback.html#enable-item-level-fallback

Also, you can do the following.

Select a fallback language in "System/Language" as below.

enter image description here

3
  • Have you tried this? Sep 5, 2022 at 11:35
  • Hi Sumith, Thanks for the response . I have attached the screenshots of the steps i have performed and i have enabled that option. Please let me know if i am still missing anything Sep 5, 2022 at 11:36
  • @HarshaVardhan I have updated my answer. Please check if you have done this. Sep 5, 2022 at 12:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.