2

I am new to Sitecore and trying to sync Sitecore content using Sitecore CLI. I am using Sitecore 10.2 version and CLI 4.2.1 version. I have installed Microsoft .NET Core SDK, ASP.NET Core Runtime

enter image description here

while I am trying to run dotnet new tool-manifest, it is giving below error:

It was not possible to find any installed .NET Core SDKs
Did you mean to run .NET Core SDK commands? Install a `.NET Core` SDK from:

enter image description here

3

1 Answer 1

1

Check if You forgot to create the dotnet tool manifest file via,

powershell dotnet new tool-manifest

Follow this blog for more details - https://thecodeattic.wordpress.com/2021/03/09/quick-start-to-the-sitecore-cli/

If this doesn't solve your issue then check below as per Can not install Sitecore.CLI for Sitecore 10

In Visual Studio 2017 or 2019:

Navigate to Tools > NuGet Package Manager > Package Manager Settings > Package Sources and remove the reference to Sitecore NuGet. This was there from a previous setup of Sitecore. My theory is that it conflicted with this installation.

Packages Sources after removing the Sitecore Source:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.