1

I had an earlier question where this problem arose during troubleshooting a Sitecore Commerce instance I ported from another server which got closed. Since then I kind of got desperate with that setup, so now this is a clean Sitecore Commerce environment (installed at the same VM). The error persists so I thought it's probably something to do with the VM configuration and other people might be able to benefit from the answer later if there is an answer.

The clean Commerce site seemingly works fine, I'm able to add habitat products to the cart etc, but when I try to bootstrap it via postman I get the following error:

Error: write EPROTO 331758216:error:100000f7:SSL routines:OPENSSL_internal:WRONG_VERSION_NUMBER:../../third_party/boringssl/src/ssl/tls_record.cc:242

Similar error in curl (I wanted to double check that it's not postman to blame):

error:0A00010B:SSL routines::wrong version number

The authoring instance itself opens fine (I get Status Code: 404; Not Found which I think is expected).

I have SSL2.0 disabled in the registry. I tried to do openssl with different -tls appendixes e.g. openssl s_client -connect commerceauthoring.myproject.local:5000 -tls1_2 but it's the same result so at this point I'm not sure what kind of connection it expects. This is the response:

C:\Users\myuser>openssl s_client -connect commerceauthoring.myproject.local:5000 -tls1_2
CONNECTED(00000148)
881D0000:error:0A00010B:SSL routines:ssl3_get_record:wrong version number:ssl\record\ssl3_record.c:355:
---
no peer certificate available
---
No client certificate CA names sent
---
SSL handshake has read 5 bytes and written 231 bytes
Verification: OK
---
New, (NONE), Cipher is (NONE)
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
SSL-Session:
    Protocol  : TLSv1.2
    Cipher    : 0000
    Session-ID:
    Session-ID-ctx:
    Master-Key:
    PSK identity: None
    PSK identity hint: None
    SRP username: None
    Start Time: 1666875167
    Timeout   : 7200 (sec)
    Verify return code: 0 (ok)
    Extended master secret: no
---

I'm hoping maybe if someone had to resolve a similar SSL issue when bootstrapping Sitecore Commerce you could lend me an advice on what else might need to be reconfigured. Thank you.

UPD: I also have Enable SSL certificate verification disabled in Postman

6
  • Interesting, so you are saying you have 2 instance of SC on single machine, right? If yes then please check if ports are different for commerce services. Oct 27, 2022 at 13:08
  • Also try to turn off Enable SSL certificate verification radio button if not already done in postman then try. Oct 27, 2022 at 13:16
  • I have Enable SSL certificate verification disabled, sorry I didn't point this out in my question. At the moment I have one instance, basically I reverted my malfunctioning one with the backups of clean wwwroot folders, databases etc which I took right after the installation
    – Elena P
    Oct 27, 2022 at 13:33
  • did you try this? -stackoverflow.com/questions/62658941/… Oct 27, 2022 at 14:07
  • I've seen that suggestion but did not try this earlier since I thought all communication within Sitecore Commerce requires https. If I post to localhost:5000{{OpsApi}}/Bootstrap() it indeed gives me a different error (500) and does not complain about ssl. Does it even make sense to try to bootstrap via http?
    – Elena P
    Oct 27, 2022 at 14:29

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.