1

I run Sitecore 10.2 with SXA in containers and I deleted all my SOLR data, SOLR Cloud have 0 collections and only a default configset in ZooKeeper.

The solr-init containers give the following error on start:

Downloading '_default' SOLR config set

Downloading 'contractions_ca.txt' file

.....

Invoke-RestMethod : 

  

    org.apache.solr.common.SolrException

    org.apache.solr.common.SolrException

  

  Base ConfigSet does not exist: sitecore_content_config

  400

At C:\Copy-SolrConfig.ps1:15 char:9

+ $null = Invoke-RestMethod -Uri $solrPostConfigUrl -Credential (Get-So ...

+         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo          : InvalidOperation: (System.Net.HttpWebRequest:Htt 

   pWebRequest) [Invoke-RestMethod], WebException

    + FullyQualifiedErrorId : WebCmdletWebResponseException,Microsoft.PowerShe 

   ll.Commands.InvokeRestMethodCommand

Downloading 'stopwords_no.txt' file

....

Tranformation managed-schema

Tranformation solrconfig.xml

SolrCollectionsToDeploy exists, skipping base configset creation.

Creating 'sitecore_sxa_master_index_config' SOLR config set based on sitecore_content_config

No indexes are created. How to fix this? I'm using the sitecore-xp0-solr-init image and sitecore-sxa-xp1-assets

1 Answer 1

0

You get this Base ConfigSet does not exist: sitecore_content_config error when you run the start.ps1 in the solr-init container when you have set a value in the SOLR_COLLECTIONS_TO_DEPLOY parameter and have not already the Sitecore base config.

The error also says it is about creating the sitecore_sxa_master_index_config, likely you have set SOLR_COLLECTIONS_TO_DEPLOY: sxa leave the SOLR_COLLECTIONS_TO_DEPLOY parameter empty, then the Base Config Set will deploy first before creating the indexes.

Take a look at your docker-compose.yml, docker-compose.override.yml e.t.c or, in the case of Sitecore Managed Cloud See the application repo, roles/sitecore-xp/templates/searchstax-solr-init-sxa-spe.yaml and adjust or set an empty value in the SOLR_COLLECTIONS_TO_DEPLOY parameter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.