1

I am getting errors when compiling my subprovider implementation (Okta) with Identity Server in Visual Studio 2022. I have followed all the instructions as described in https://doc.sitecore.com/xp/en/developers/102/sitecore-experience-manager/use-the-sitecore-identity-server-as-a-federation-gateway.html This is all working fine when compiling in Visual Studio 2019.

1 Answer 1

0

Unfortunately, the Sitecore.Framework.Runtime.Build SDK as outlined in the documentation only works for .Net Standard 2.1, which is not compatible with Visual Studio 2022 Build Tools. The project must be built against Visual Studio 2019 Build Tools.

To build the project in Azure Pipelines, use the windows-2019 agent. To build the project inside a docker container, use mcr.microsoft.com/dotnet/framework/sdk:4.8-20211012 which contains Visual Studio 2019 Build tools.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.