1

I'm trying to create new jss app for Sitecore 9.3. I have installed sitecore jss-cli version 13.0. When I try to create new jss app using "jss create" command nothing is happening. where in I'm able create an app using the command "npm init sitecore-jss". It looks like create command itself is not available. Node version installed: v18.12.1 JSS CLI version: 13.0.0 npm version: 9.1.2

JSS CLI issue

1
  • It seems it was something to do with Node version. I was having latest node and npm, But JSS 13 uses lower version of node and npm (required: { node: '>= 10.13.0', npm: '^6.11.0 || ^7.5.6', yarn: '>= 1.13.0' }). post downgrading the node and npm version. I was able to create and run the jss app.
    – Prem2530
    Dec 2, 2022 at 5:13

2 Answers 2

0

I think this issue is because of the Node js version over the period of time few dependent packages are deprecated. Therefore it does not support the latest node/npm version.

I tried the below steps and it got resolved:

  1. Install node js version 13.14.0
  2. Add jss CLI globally using : npm install -g @sitecore-jss/[email protected]
  3. jss create my-jss-app angular --branch release/13.0.0

enter image description here

1
  • Thank you @Sumit Helaiya for me installing the node version "10.13.0" helped
    – Prem2530
    Dec 2, 2022 at 8:42
1

As per the Sitecore documentation for JSS, you should run this command before creating the app.

npm i @sitecore-jss/sitecore-jss-cli@<version>

And then run the create command like this.

jss create my-jss-app angular --branch release/13.0.0

And then follow the other steps mentioned in this document.

Refer to this article for more details.

https://doc.sitecore.com/xp/en/developers/hd/200/sitecore-headless-development/create-a-jss-app-for-an-older-version-of-sitecore.html

1
  • I do followed the steps but looks like a node version is the issue, after downgrading the node version to "10.13.0", it worked.
    – Prem2530
    Dec 2, 2022 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.